not working on cubieboard with Linaro-Precise-Alip

Discussion about DroidMote Server for Linux on ARM cpu
User avatar
zulu99
Site Admin
Posts: 2485
Joined: Tue Oct 09, 2012 6:42 am

Re: not working on cubieboard with Linaro-Precise-Alip

Postby zulu99 » Thu May 16, 2013 6:56 pm

we need all the kernel source code, for your version 3.4.24-a10

we need the github link for the version 3.4.24-a10

Please can you attach in this forum a module already compiled for your kernel, that you can find in your distro. Any file with extension .ko

In this mode i can see the exact vermagic, and when i have a little time i try to compile the module for you if i found the github link of your exact kernel source code


p.s.
I deleted your previous file because it alone is useless
Developer of DroidMote Server and DroidMote Client. Read the Quick Start Guides and then I'll be happy to help.
Donate with Paypal or Donate with Crypto

User avatar
zulu99
Site Admin
Posts: 2485
Joined: Tue Oct 09, 2012 6:42 am

Re: not working on cubieboard with Linaro-Precise-Alip

Postby zulu99 » Fri May 17, 2013 10:58 am

I don't know if it work. But try this:

uinput.ko 3.4.24-a10-aufs+ preempt mod_unload modversions ARMv7

copy in /lib/modules

chmod 644 /lib/modules/uinput.ko

insmod /lib/modules/uinput.ko

p.s.
If this don't work, please attach to me a file with .ko extension from your Linux distro.
You do not have the required permissions to view the files attached to this post.
Developer of DroidMote Server and DroidMote Client. Read the Quick Start Guides and then I'll be happy to help.
Donate with Paypal or Donate with Crypto

seahorse
Posts: 16
Joined: Mon May 13, 2013 12:45 pm

Re: not working on cubieboard with Linaro-Precise-Alip

Postby seahorse » Mon May 20, 2013 2:07 pm

Hi again,
i tried out your attached uinput.ko but without success :(
Now I have to admit that my cubieboard setup is somehow "complicated". As stated, I'm using berryboot to start up my cubieboard which gives me the advantage that I can switch between different distro's. However, I somewhere found some info that this implies that the modules are schared in between the distro's and I'm not sure anymore which modules get loaded.
I wanted to avoid going to the next step as I didn't really wanted to "struggle" again setting up my distro to my wishes but I guess there's now other choice so ...
I decided to make a new sdcard with only the linaro-precise-alip-20121124-519_1G-v2 installed.
The version of this distro seems to be 3.4.24 preempt mod_unload modversions ARMv7 p2v8 but for good measure I attached one of the modules as requested.
Not willing to take advantage of your kind help, I've been trying to compile the uinput.ko module myself over the weekend (hence my late response) using this guide http://www.cyberciti.biz/tips/compiling ... odule.html but without success. I cant find the linux-headers-3.4.24 anywhere :cry:
So sorry to say that I have to call on your help again.
Thanks for your patience.
You do not have the required permissions to view the files attached to this post.

User avatar
zulu99
Site Admin
Posts: 2485
Joined: Tue Oct 09, 2012 6:42 am

Re: not working on cubieboard with Linaro-Precise-Alip

Postby zulu99 » Tue May 21, 2013 7:47 am

try this

vermagic = 3.4.24 preempt mod_unload modversions ARMv7 p2v8
You do not have the required permissions to view the files attached to this post.
Developer of DroidMote Server and DroidMote Client. Read the Quick Start Guides and then I'll be happy to help.
Donate with Paypal or Donate with Crypto

seahorse
Posts: 16
Joined: Mon May 13, 2013 12:45 pm

Re: not working on cubieboard with Linaro-Precise-Alip

Postby seahorse » Tue May 21, 2013 8:51 am

Unfortunatly that didn't work too :(
I still get "-1 invalid module format.
I checked again with modinfo other modules in the /lib/modules and they have the exact same vermagic as the module you attached.
I also ran the depmod -a command and the uinput module shows up in the module.dep and I don't have to specify the path anymore.
Puzzled .... :?

User avatar
zulu99
Site Admin
Posts: 2485
Joined: Tue Oct 09, 2012 6:42 am

Re: not working on cubieboard with Linaro-Precise-Alip

Postby zulu99 » Tue May 21, 2013 9:10 am

Look at output of dmesg for more info on error messages associated with kernel modules, and use the modinfo command on the kernel module to peek into kernel module.

without your device in my hand i can't help you well.
Developer of DroidMote Server and DroidMote Client. Read the Quick Start Guides and then I'll be happy to help.
Donate with Paypal or Donate with Crypto

seahorse
Posts: 16
Joined: Mon May 13, 2013 12:45 pm

Re: not working on cubieboard with Linaro-Precise-Alip

Postby seahorse » Thu May 23, 2013 4:40 pm

Hi,
I understand it is difficult to look for the solution if you don't have the device to play around with. I did some more research and checked the dmesg and there's a problem with the module_layout which is different than from the other modules. I found a way to adjust it with a hex editor but then it gives a invalid_argument error or so.
Anyway, I'm trying to build my own kernel, still struggling with it, but I guess it's a learning school.
Many thanks anyway for all your kind help, it's much appreciated.
If I ever come to a solution I will post it here.
Cheers


Return to “DroidMote Server for Linux on ARM cpu”

Who is online

Users browsing this forum: No registered users and 1 guest