[ROM][Full Android Oreo for Shield TV][v.1.10]

Full Android Experience with NO Limits on Shield TV and Nexus Player
Posts: 29
Joined: Sun Jan 13, 2019 4:51 pm

Re: [ROM][Full Android Oreo for Shield TV][v.1.10]

Postby Lenana » Tue Oct 15, 2019 9:20 am

Rechims wrote:
Lenana wrote:Unfortunately I was unable to install this ROM. I'm on 7.2.3 shield pro 2017. Everything flashes successfully but the device never goes past the colourful loading (booting) screen. I am hoping zulu99 will release another version that will be compatible with all devices.

It might help if you boot into fastboot with the controller pressing AB, than choose factory reset.

I had the same thing on Shield 2017 16GB, I got an error with the -w command, didn't pass the Android animation. But factory reset solved it.

Hey:) I managed to install it finally with the help of @zulu99. This is what I did.
1. Factory reset from boot loader. Took about 1 hr as I have a 500GB SSD.
2. I flashed developer 7.2.2 firmware from nvidia using the instructions provided at their website.
3. I then flashed over system.img and vendor.img from 'Full android v1.10' and alas! it booted!
4. I then installed magisk by patching boot.img from the developer 7.2.2 firmware using the magisk app then flashed it. Everything works well now.

Note: Flashing full android on developer 7.2.3 image resulted in broken wifi and bluetooth for me. But flashing on dev. 7.2.2 firmare fixed the radio issue.
I hope this post helps someone out there. Cheers!

Posts: 3
Joined: Sun Oct 13, 2019 5:50 am

Re: [ROM][Full Android Oreo for Shield TV][v.1.10]

Postby Davicom » Tue Oct 15, 2019 7:27 pm

@Lenana can I know how can I download 7.2.2 dev fw? On Nvidia site Is available Just to developers. Could you help me to know where I can download It?

Posts: 1
Joined: Sun Sep 01, 2019 2:04 pm

Re: [ROM][Full Android Oreo for Shield TV][v.1.10]

Postby FORUST » Mon Oct 28, 2019 10:59 am

need update the file for the VMware hardware acceleration please upate the file becasue you get now issue update for VMware 15.5.

Posts: 3
Joined: Thu Feb 09, 2017 4:13 pm

Re: [ROM][Full Android Oreo for Shield TV][v.1.10]

Postby lukecastle » Thu Nov 07, 2019 1:45 am

Is anyone else having a "system ui has stopped" fault? :?:

Posts: 29
Joined: Sun Jan 13, 2019 4:51 pm

Re: [ROM][Full Android Oreo for Shield TV][v.1.10]

Postby Lenana » Mon Nov 25, 2019 11:14 am

@Davicom sorry for the late response. The 7.2.2 image is available at nvidia site but you have to register as developer.

Posts: 1
Joined: Sun Nov 17, 2019 11:31 pm

Re: [ROM][Full Android Oreo for Shield TV][v.1.10]

Postby pop4doid » Tue Nov 26, 2019 4:44 am

I'm on developer firmware 8.0.1. Can I flash stock 7.2.2 in order to try this full Android Oreo?

Ps. I did tried full Android Pie but still too many bugs eg. UI color. Does this Oreo has any annoyng bugs?

Posts: 9
Joined: Tue Oct 31, 2017 5:50 pm

Re: [ROM][Full Android Oreo for Shield TV][v.1.10]

Postby txintxigorri » Tue Nov 26, 2019 6:54 pm

Hi all

I have installed Full Android Oreo following the instructions.

I have the bootloader patched by magisk and the root works.

I activate the developer options and when I am going to activate the usb debugging (in developer options) I get the error of the usb port is in use and it does not let me activate it.

I have nothing connected to the USB ports, I use the original remote control wirelessly.

What can be?
What can I do to fix it?

Greetings from Spain.

Posts: 38
Joined: Wed Feb 01, 2017 4:33 pm

Re: [ROM][Full Android Oreo for Shield TV][v.1.10]

Postby PLAY911 » Tue Nov 26, 2019 10:13 pm

Hi its in the 1st page of this thread....la tuya es la de 2017?
Un saludo
⬤ How to make the 2nd USB port of the SATV 16GB 2017 work normally again:

# Root required #
When Full Android is installed, by default the 2nd USB port of the Shield TV 16GB 2017 work for ADB/Debug only.

In order to recover normal functionality back and be able to use USB debugging and Host mode at the same time

you need to add the following to the build.prop and then save the changes (preferably right after you install the firmware and boot for the first time):



YOU MUST FACTORY RESET YOUR SHIELD TV AFTER THIS because the firmware must start with this string already inside the build.prop for it to work.

For my reference, and for others developers, at low level happen this:

To enable USB-HOST:

echo USB-HOST > /sys/class/exton/ID/connect

To disable USB-HOST:

echo none > /sys/class/exton/ID/connect

Posts: 1
Joined: Fri Dec 13, 2019 1:44 pm

Re: [ROM][Full Android Oreo for Shield TV][v.1.10]

Postby gumymoty » Fri Dec 13, 2019 2:05 pm

Need help, I'm got a nvidia shield tv 2017, i hate tv android version no full play store,no touch support, can't use controller mapper like on my nvidia tablet, in this custom rom? That can be similar like nvidia k1 tablet rom version, What is the disadvantage use a full android instead tv version? This is stable rom.?

Posts: 1
Joined: Sun Dec 22, 2019 2:31 pm

Re: [ROM][Full Android Oreo for Shield TV][v.1.10]

Postby KINSOMNIACX » Sun Dec 22, 2019 10:13 pm

I been struggling for the past 2 weeks as netflix gives me error i have reinstalled the rom clean tried android pie and netflix app works but cant get it to work with android oreo any way to fix this please?

Return to “Full Android firmwares for Shield Android TV, Nexus Player and PC”

Who is online

Users browsing this forum: No registered users and 8 guests