Running at startup on ubuntu

Discussion about DroidMote Server for Linux
nashant
Posts: 2
Joined: Sun Nov 18, 2012 1:25 pm

Running at startup on ubuntu

Postby nashant » Sun Nov 18, 2012 4:02 pm

Hi, I'm trying to get this running on boot with linux, but no luck. Could you post a suitable init.d script with start/stop/restart please

User avatar
zulu99
Site Admin
Posts: 2483
Joined: Tue Oct 09, 2012 6:42 am

Re: Running at startup on ubuntu

Postby zulu99 » Sun Nov 18, 2012 5:08 pm

Inside the Readme of DroidMote Server for Linux you can find the exact procedure to start it on boot.

DroidMote Server for Linux must start after X11. Remember this, is very important to have all working.
Developer of DroidMote Server and DroidMote Client. Read the Quick Start Guides and then I'll be happy to help.
Donate with Paypal or Donate with Crypto

nashant
Posts: 2
Joined: Sun Nov 18, 2012 1:25 pm

Re: Running at startup on ubuntu

Postby nashant » Mon Nov 19, 2012 12:35 pm

How do I ensure that it starts after X11? I've tried doing what's in the readme, but no luck. All I get is 'Server is not reachable'

User avatar
zulu99
Site Admin
Posts: 2483
Joined: Tue Oct 09, 2012 6:42 am

Re: Running at startup on ubuntu

Postby zulu99 » Mon Nov 19, 2012 2:34 pm

I tested again what is written in the readme and it work.

Look in the process if the server is started, if you have the port listening.

But for first, try to ping your phone from your linux pc. If the ping not work you have connections problem indipendent from droidmote.
Developer of DroidMote Server and DroidMote Client. Read the Quick Start Guides and then I'll be happy to help.
Donate with Paypal or Donate with Crypto

User avatar
zulu99
Site Admin
Posts: 2483
Joined: Tue Oct 09, 2012 6:42 am

Re: Running at startup on ubuntu

Postby zulu99 » Mon Nov 19, 2012 5:07 pm

this is the exact procedure wriyyen in the readme:

How to start the server:

Disable the firewall on port 2302
chmod 777 ./droidmote
sudo su
./droidmote 2302 password


How to start the server at boot time automatically: (you can use also an alternative configuration, but you must start droidmote after X11)

get root permission with sudo su
copy droidmote to /usr/bin
chmod 777 /usr/bin/droidmote
create a shell script startdm.sh in /usr/bin

-----------------------------
the content of startdm.sh is:
#!/bin/sh
droidmote 2302 password &
-----------------------------

chmod +x /usr/bin/startdm.sh
edit the file /etc/lightdm/lightdm.conf and add the line: greeter-setup-script=/usr/bin/startdm.sh
restart your machine
Developer of DroidMote Server and DroidMote Client. Read the Quick Start Guides and then I'll be happy to help.
Donate with Paypal or Donate with Crypto

CRS86
Posts: 1
Joined: Sat Dec 01, 2012 10:48 am

Re: Running at startup on ubuntu

Postby CRS86 » Sat Dec 01, 2012 11:20 am

At first this setup didnt work for me.

though after i moved the startdm command further up the list in the wm config file it worked a treat.

Greg_f
Posts: 1
Joined: Mon May 27, 2013 7:38 am

Re: Running at startup on ubuntu

Postby Greg_f » Mon May 27, 2013 7:53 pm

output of sudo nano /etc/rc.local

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
droidmote 2302 password &
exit 0



that solevs start up issue


Return to “DroidMote Server for Linux”

Who is online

Users browsing this forum: No registered users and 2 guests